
Nr2k3 PTF to GTR2 track conversion tutorial
Dave Noonan

With many thanks to Steve [dB] Dienes.

Required Tools:

Sim Garage:

TrkMaker, at least version 1.7 and 3dSimEd at least version 1.14

Nvidia:

DDS Thumbnail Viewer (helpful but not required)
http://developer.nvidia.com/object/dds_thumbnail_viewer.html

Text Editor:

Any text editor will do. Notepad, Textpad etc.

1. Preparation

For this example, we will use the track name “MyTrack”
Set up a work space directory; C:\Locations
Then create the root directory for your track, C:\Locations\MyTrack , this will hold the
data from the track we are converting. Within this folder we need two temporary folders:
C:\Locations\MyTrack\MyTrack_dat and
C:\Locations\MyTrack\shared

Within GTR2 we need a track folders with a sub-folder to hold the geometry and textures.

GTR2\GameData\Locations\MyTrack and
GTR2\GameData\Locations\MyTrack\Objs

Open 3dSimEd, and from the Tools menu, select Expand–Papyrus DAT. Navigate to where your
original nr2k3 track is located and select your Mytrack.dat file.
Next, point 3dSimEd to your C:\Locations\MyTrack\MyTrack_dat folder and
extract the .dat file to that location.
If your track was not packed into a .DAT file, then just copy the files to your
C:\Locations\MyTrack\MyTrack_dat workspace.

Now copy the .LP files, the .CAM and Track.ini from the nr2k3 track to your
C:\Locations\MyTrack\MyTrack_dat folder.

Most tracks will also contain objects and textures held in the N2K3 shared folder.
Using the Tools->Expand->Papyrus .DAT function select the SHARED.DAT within the n2k3
Tracks\Shared folder and extract the files to C:\Locations\MyTrack\shared

We are now going to use 3DSimED to ensure all our textures are in one place. Open
MyTrack.PTF from C:\Locations\MyTrack\MyTrack_dat. Select the File-
>Export Textures function and select C:\Locations\MyTrack\MyTrack_dat as the
target folder (you can skip the option to Rename Textures... ).



We should now have all the textures used by the n2k3 track in the folder
C:\Locations\MyTrack\MyTrack_dat.

2.Texture conversion.

Use the Texture Browser in 3dSimEd and navigate to your
C:\Locations\MyTrack\MyTrack_dat folder. Click on Batch Conversion.
Select all of the .mip files and choose .DDS as the format to convert to. Point 3dSimEd to your
GTR2\GameData\Locations\MyTrack\Objs and you will now have all your texture
maps as .DDS files.

3. Converting with TrkMaker.

3.1.Converting the Track Surface

Open TrkMaker and select Nascar .PTF to XML
Navigate to C:\Locations\MyTrack\MyTrack_dat and select MyTrack.ptf
Save as MyTrack.XML.

Use the OpenXML command and then from the edit window select the Write GTR option.
Navigate to GTR2\Gamedata\Locations\MyTrack\Objs and save.
You will now have all of your track segments as .gmt objects and you will also have a file named
_trkmaker.trk

You may, want to check your progress so far by opening _trkmaker.trk with 3DSimED.
Check that all faces generated by TrkMaker have textures assigned.
The quick way to confirm this is to use Tools->Missing Textures & Objects. If there are missing
textures then you need to look at the Materials table within TrkMaker.

3.2.Creating Response objects.

For the AI, and the correct timing of laps, GTR2 needs a number of special response objects. These
objects can be created in TrkMaker using the VerticalObj table. Using the TrkMaker Open XML
command open the MyTrack.XML you created from the .PTF.
For each vertical object you need to define the longitude, latitude of the left and right of the object,
bottom elevation, height and the material name. You will also need to give the title of the object
which should be from the list below.
With the XML open go to the VerticalObj table (you may need to scroll down the list of tables
on the left)

1) Xfinish. An object which spans the track (including the pit lane) at the start/finish line.
Normally this object would have longitude of zero.

2) XSector1 & XSector2. As the names suggest these two objects span the track at the end of
sectors 1 and 2 and should have longitudes of approximately 1/3rd and 2/3rd around the track

3) XPitin & XPitout. These objects mark the start and end of the pitlane. You need them to
span the pitlane but not overlap any of the racing surface.

To get the correct longitudes and latitudes for these objects you can open your original N2K3 .PTF
with 3DSimED and move the mouse over the track watching the bottom right of the status bar for
the three values labeled LLE which are the longitude, latitude and elevation of the cursor position.



Alternatively, by right clicking and selecting Memorize XYZ these values will be copied as text to
the clipboard and you can paste them into notepad to read or copy.

For each of the five objects make sure the Material is one already present in the Material table (e.g.
road01), set the bottom elevation to -2 and the height to 10 ( we are attempting to create objects that
cannot be missed so we are drawing it from 2m below the track surface to 8m above the surface).
You would normally set the LongEnd to the same as the LongStart ensuring the object is
perpendicular to the track. The LatStart is the left latitude and LatEnd the right latitude.

Once all five objects are added to the VerticalObj table, use Write to XML, and then use the
Write GTR2 function to re-create the track surface objects in the
GTR2\Gamedata\Locations\MyTrack\Objs folder.

3.3.Track texture transparency.

TrkMaker is a database application with no knowledge of the transparency of the textures used for
the track surface so it sets all the materials to have no transparency when writing the .GMT. It is
almost certain that your original N2K3 track used textures that have transparency so this issue has
to be resolved.
The quick way to do this: with 3DSimED. Import _trkmaker.trk into 3DSimED. You should
now see the response objects we created above as well as the track surface. If everything is as you
expected use Edit->Material Operations->Reset Material Transparencies
and you should see a difference wherever there are transparent textures. Now using File->Save
as GTR2 GMT->Save Objects, saving the objects back to
GTR2\Gamedata\Locations\MyTrack\Objs

A better way to deal with the transparencies is, within TrkMaker, to open the Material Table and to
set the values of the Transparency fields. The advantage of this method is that you only have to do
it once and you will not have to use 3DSimED to reset the transparencies every time you export
.GMTs from TrkMaker. The Transparency field should be zero for no-transparency (e.g. asphalt,
grass paint etc), one for simple transparency (e.g. Armco) and two for multiple transparency (e.g.
wire fences). If you are not sure you can always use the Tools->Texture Browser of
3DSimED to look at the textures.

4.Converting the TSO objects

From within 3DSimEd and from the File Menu, select Import Model.
Open your MyTrack.ptf file.

The first thing we need to fix is a material named "*GENERATED BY DEFAULT*
If you don’t see this material, don’t worry about it. It is not part of our track and is created by 
3dSimEd. Click on the material name, and click the Edit button. An * is not allowed by GTR2 in
a material name so we will change it to Null. Also, notice that the texture that is assigned to it
has no name. Click the button with the texture name, and assign any texture to it. It does not matter
which one you choose.

At this point we should delete the flaggers as these objects have no purpose in GTR2.
The quick way to do this is to go to Display->Object Filter and select All Off. Now
switch back on the display of flagger*.3do objects, and exit with OK. With Edit->Select



All Displayed you should get a sub-menu with Objects, and from the Objects menu select
Erase. With Display->Object Filter All On switch on the display of all your remaining objects.

If there are animated objects from the shared folder such as flag.3do, flag_large.3do,
flag_xlarge.3do, truck_jumbotron.3do, & truck_led.3do you should delete
this objects. The same applies to any flying objects such as blimp.3do, Cessna.3do, and
heli*.3do.

From the File Menu, select Save As GTR2 GMT->Save as objects
Point 3dSimEd to your GTR2\Gamedata\Locations\MyTrack\Objs folder and save.
Now all of your TSO .3do objects are .gmt objects and you will also have an _output.trk
file in which they are listed.

At this point, use 3DSimED to Import the _ouput.trk that has just been created to check for
missing textures (Tools->Missing Textures & Objects) .

5. Setting up the track configuration files.

5.1.Info

First, let’s take a look at these file extensions and what these files do. Most of these files can be
viewed and edited with Notepad or other text editors. (You may need to right-click the file and
select Open With and select Notepad)

.trk (scene) this file lists all of the objects the game will load when loading your track.
It also contains the file paths to search for them, and information about lighting and fog values.
Special properties for objects such as movable and vis groups (controls whether the object
is hidden at low graphic detail settings) are also controlled by this file. When writing a track
surface to GTR2 objects, TrkMaker creates _NoName.trk which contains a header for a .trk file.

.gdb contains the information about your event; Name, description, session details, pit speed,
etc. Again those supplied with GTR2 are encrypted but we can create plain text versions of .GDB
which will be accepted by GTR2.
When writing a track surface to GTR2 objects, TrkMaker creates _NoName.gdb which can be
modified for a specific track.

.cam This is the camera file and TrkMaker can convert from N2K3 format to GTR2 format for
you.

.aiw This is the AI file and includes the equivalent information as the GPL .lp files and portions
of the track.ini. It contains the pit, garage, pace/safety car and start grid locations. TrkMaker can
create .AIW files.

.ani This file controls animations. TrkMaker will write you a blank file to use.

.grd Seems to be identical for every track. TrkMaker will write a copy identical to those used at
the default GTR2 tracks.

Track.bmp and _LOD.JPG graphics files to display the track map and the loading screen.
Curiously, the Track.bmp file is in fact in .TGA format not .BMP format. Hence, to edit you will
need to copy it to TGA and then back to .BMP.



5.2.Borrowing files

Now that we know a little bit about the files we will be working with, we will need to borrow
some existing ones to get us started.

The files we are missing are for the track maps, loading screens etc. We will use those from
Zhuhai as there is only one event at this track and that makes finding and copying the files easy.

Copy GTR2\Gamedata\Locations\Zhuhai\4ZhThmb.tga to
GTR2\Gamedata\Locations\MyTrack\MyTThmb.tga (note that the first 3 letters of
the track name are used)

Copy 4Zhu_LOD.jpg and 4Zhu_Lod_2.jpg to MyTr_LOD.jpg and MyTr_LOD_2.jpg. (first 4
letters of the track name are used).

Lastly, copy 4ZhuhaiTrack.bmp to MyTrack.bmp

At this point we also need the files that TrkMaker has created for. From
GTR2\Gamedata\Locations\MyTrack\Objs copy all the _NoName.* files to
GTR2\Gamedata\Locations\MyTrack\MyTrack.* .

When finished you should have four MyTrack. Files in the folder
GTR2\Gamedata\Locations\MyTrack

5.3.Create horizon object

You must create an horizon object for your track otherwise it will not load in GTR2.
Open any of the GTR2 .TRK files (or, for this, you could use an rFactor .SCN). Right click on the
sky object (should be very obvious as it will cover the track) and from the context menu select
Edit skyboxi. From within the Edit Object dialog choose the operation Isolate and you should get
the horizon in a new drawing window (you don’t see the rest of the sky because it is made up 
from nested objects which are ignored by Isolate). If you feel the horizon is suitable for your track
use File->Export Texture to save the textures to
GTR2\GameData\Locations\MyTrack\Objs. Now save the skyboxi.gmt using File-
>Save As GTR2 .GMT->Save Model Data, leaving the .GMT Write Options are they are, and
make sure you save to the GTR2\GameData\Locations\MyTrack\Objs.

5.4.Editing the configuration files

5.4.1.MyTrack.GDB

Open _NoName.gdb (from GTR2\GameData\Locations\MyTrack\Objs) with a
text editor such as Notepad.
The opening line must match the title of the track, otherwise the track will not show up in the
track list in GTR2. Go through the .GDB replacing all the NoName entries. At the same time you
may wish to edit some of the other data for the track.
Save As GTR2\GameData\Locations\MyTrack\MyTrack.gdb.

MyTrack
{
AI Vehicle Filter = MyTrack

TestDayDay = Wednesday
TestDayStart = 7:00



Practice1Day = Friday
Practice1Start = 10:00
Practice2Day = Friday
Practice2Start = 16:00
Qualify1Day = Saturday
Qualify1Start = 9:00
Qualify2Day = Saturday
Qualify2Start = 16:00
WarmupDay = Sunday
WarmupStart = 9:10
RaceDay = Sunday
RaceStart = 11:30
RaceLaps = 118
RaceTime = 180
RaceTimeScaled = 180

Attrition = 15

TrackName = MyTrack, FIA GT Championship Round 00
GrandPrixName = MyTrack, 2004

5.4.2.MyTrack.TRK

Open _NoName.trk (from GTR2\GameData\Locations\MyTrack\Objs)with a text
editor

The first section of the .trk file determines the search paths for your track files:
Replace references to NoName with MyTrack. Note the reference to skies_central.GTR2
which is essential for the sky objects referred to later on in the .TRK file.

CUBEASF

//-------------------------------------------------------

SearchPath=GAMEDATA\LOCATIONS\SHARED
SearchPath=GAMEDATA\LOCATIONS\NONAME
SearchPath=GAMEDATA\LOCATIONS\NONAME\OBJS
//-------------------------------------------------------

MASFile=Skies_central.gtr
MASFile=teammaps2.gtr
MASFile=Misc.gtr

//MASFile=MYTRACK.GTR
//MASFile=MYTRACKMAP.GTR

The // are comment characters and anything to the right will be skipped. MyTrack.GTR and
MyTrackMap.GTR can be created later.
Save the trk file to GTR2\GameData\Locations\MyTrack\MyTrack.trk.

Now open your _trkmaker.trk file (GTR2\GameData\Locations\MyTrack\Objs)
with a text editor. Select all of the text in _trkMaker.trk and copy it to the clipboard.



Paste all of this at the end of MyTrack.trk.
Close _trkMaker.trk

Open _ouput.trk, select all of the text, copy it to the clipboard.
Paste the text to the end of MyTrack.trk
Close _ouput.trk

Save and close MyTrack.trk

6. Creating the AI.

The file MyTrack.AIW needs AI information for MyTrack. TrkMaker can help make a very
basic, limited, AIW file which will get us started.

In TrkMaker open your MyTrack.XML. We need to complete the AIInfo table before creating
the AIW (you may need to scroll down the list of tables to get to AIInfo).

All the values must be present. MergePitIn and MergePitOut are the longitudes at which the AI cars
will merge to and from the pit line. StallsLongStart, and StallsLatStart give the longitude and
latitude of the pit stall at the start of the pit lane while StallsLongEnd and StallsLatEnd are for the
end of the pit lane.

TrkMaker reads these values from the Track.ini file, providing it is in the same folder as the .PTF.
If any of the values are zero or your AIInfo table is empty you will need to fill in the values by
hand. You can use 3DSimED to help get these positions for you moving the mouse over the track
watching the bottom right of the status bar for the three values labeled LLE which are the longitude,
latitude and elevation of the cursor position. Alternatively, by right clicking and selecting
Memorize XYZ these values will be copied as text to the clipboard and you can paste them into
notepad to read or copy.

Once you have completed the AIInfo table hit the Write AIW button. You will be prompted
for .LP files so navigate to your C:\Locations\MyTrack\MyTrack_dat folder and
select one of the .LP files. Next you will be prompted for the AIW filename, browse to the your
GTR2\GameData\Locations\MyTrack\ folder and write MyTrack.AIW

7. Converting a Camera file

TrkMaker can convert N2K3 .CAM files to GTR2 .CAM files. With MyTrack.XML opened in
TrkMaker select the Cam Converter button. You will be prompted for your N2K3 .CAM file and
then the name of the GTR2 .CAM file to create which will be
GTR2\GameData\Locations\MyTrack\MyTrack.cam. The GTR2 .CAM file is a text
file which you can edit yourself.



8. Testing and troubleshooting.

Start GTR2 and select MyTrack for a testing session.

If all went well, have fun turning a few laps and you should be also able to sit back and with
CTRL-I let the AI take over the driving while you enjoy the scenery. If everything is working
then you might want to move on and create some reflection objects for wet races (see the next
part of the guide).

If your track does not show up in the track list then you have probably made a mistake in the top
line of MyTrack.GDB.

If GTR2 failed to load the track because of a problem with missing textures, you will get a
message which should help you to find which texture is missing. If you are getting no error
message try running GTR2 with the argument trace3 and then open trace.txt from the
UserData\LOG folder and read the trace particularly at the end of the file.

If the trace.txt does not help, and you are crashing about 75% through loading then it may well be
that there is a problem with the .AIW file.

8.1.Another way to create the AIW.

Look for the GTR2 track this seems closest in length (but longer). Copy this AIW over
MyTrack.AIW in the GTR2\GameData\Locations\MyTrack\MyTrack folder.

We now need to determine our garage location for where the car will appear when we first enter the
track.

Import the either the original N2K3 .PTF or the
GTR2\GameData\Locations\MyTrack\MyTrack\MyTrack.trk to 3dSimEd and
rotate so you are looking down at the track and place your cursor over a spot on your pitlane. Write
down the XYZ coordinates that are displayed in the lower right side of the 3dSimEd window.
Close 3dSimEd

Open MyTrack.AIW with notepad. Scroll down through the starting grid entries and look for
this section:

[PITS]
TeamIndex=0
PitPos=(53.345,-2.370,-385.856)
PitOri=(-0.001,-1.526,0.000)
GarPos=(0,52.901,-2.370,-382.767)
GarOri=(0,-0.002,0.003,0.001)
GarPos=(1,50.156,-2.370,-382.759)
GarOri=(1,-0.002,0.003,0.001)
GarPos=(2,46.933,-2.370,-382.749)
GarOri=(2,-0.002,0.003,-0.001)

GarPos (Garage Position) is the location where your car appears when you first enter the track.
Depending on the track, the garage and pit locations may or may not be the same, but for the
purpose of this tutorial, we will assume that they are.
There are 3 possible garage locations for each pit stall and each is indicated by the index numbers 0,
1, 2. Be careful not to remove these index numbers when entering your coordinates.



The series of numbers are: (<index>,<X coordinate>,<Z coordinate>, <Y coordinate>)
*** Important*** notice that the coordinates are in XZY order, not XYZ. Pay attention to this
when you enter the coordinates that you obtrained from 3dSimEd.

Enter the same coordinates for PitPos and GarPos.

The PitOri and GarOri ( orientation ) entries control the Pitch, Yaw and Roll of the
position.

Save and close MyTrack.AIW

Now try opening the track with this new MyTrack.AIW

Before testing this new .AIW make sure you delete
GTR2\GameData\Locations\Hat_Dedicated\MyTrack.Hat

IF you have no luck you could try an .AIW from another track, repeating the process above.

8.2.Track Surface Materials

If you are having problems driving some of the surfaces or you think the surface should have
different grip levels then you will need to edit the material names (Not the texture names, they
can be named anything), but the materials must be named by surface types defined in
GTR2\gamedata\locations\specialfx.tec

These rules apply to driving surfaces, there is no need to change the material names of the track
details used for the start line etc.

By default, the materials defined in the .tex are:

Legal Material Names
Roads: road,conc
Grass: gras
Sand/Gravel: grv, sand, grav
Rumblestrips: rmbl
Hard wall: cema, cmwl
Tirewalls: twal
Barriers: grdr

The material name has to match something in the specialfx.tec file. More correctly, the material
name has to start with a name defined in specialfx.tec.
So a valid name for a road material could be roada, road1, or roadzzzz and so on.

If a drivable surface is not named correctly, your car will get stuck and sink into it. Grass, paint
lines, asphalt, cement, dirt/gravel and rumble strips must be named correctly.

For the walls the material name does not have to match one defined in the specialfx.tec but you will
just get a solid wall if there is no match. For softer walls you will need a material prefixed with
twal.

In TrkMaker open your TractionTex table and look at the Tex field.



For each TractionTex surface check the prefix of the material name and make sure it matches one
of the prefixes defined in GTR2\gamedata\locations\specialfx.tec.

If you need to change a material name you are going to also have to reflect that change in the
Material table.

The materials for the walls are defined in the WallTex table and again you should check for
matches to walls in GTR2\gamedata\locations\specialfx.tec.
Again, if you change a material name the material table will also need editing.

Once you have done this you will obviously have to let TrkMaker write your GTR2 objects again to
GTR2\Gamedata\Locations\MyTrack\Objs.

Note a quick way of changing the material names is to do the renaming in 3DSimED. Import
_TrkMaker.trk and use the Edit->Material Editing to check/edit the material names. However,
changing the material names in TrkMaker ensures you can keep your changes for every time you
need to write the track.

9. Creating rain/reflection objects

The tracks included with GTR2 can display a wet track surface which reflects the cars and other
objects. 3DSimED can create the objects required for this feature.

9.1.Create rain objects

The first stage is to create some duplicates of the track surface objects. Rain objects must be
prefixed with rrefllect.
From the command line in the GTR2\Gamedata\Locations\MyTrack\Objs folder
Copy TrackObj*.gmt rreflect*.gmt will give us the filenames we need. The next small
step is very important; GTR2 requires one of the objects to be named rreflect01.gmt so rename
rreflect001.gmt to rreflect01.gmt.

9.2. Deleting geometry

Within 3DSimED use the File->Import As Object to open all the rreflect files. We now must delete
all the geometry for materials which do not collect water. These will be grass, sand, gravel, curbs
etc. and all the walls. Select Edit->Material Operations->Erase Material Geometry. From the list of
materials select the materials to delete (you can multi-select materials in this dialog). You may find
it useful while deleting some materials to use Edit->Purge->Unused Materials which will remove
materials from the list that have no geometry. When you have finished deleting make sure you
Purge Unused Materials otherwise the next stages could get confusing.

9.3. RREFLECT material

The next stage is to create a special material to mimic the reflection of water. Use Edit->Material
Editing to create a new material. Name the material rreflect and then in the select the texture button,
entering the name rreflect00.dds in thetexture browser. Don’t worry that this texture does not exist 
in your track folders because it will be found by GTR2 in the MISC.GTR included at the top of
your .TRK file. There are three more textures to add to the material. Click the Enabled check box
for the Specular Map, to switch it on, and then select the Add Map button setting the texture map
name also to rreflect00.dds. Enable the Bump Map, and set the Mult. Map to dryingline.dds, set the
Cube Map to enabled, the Mult. Map to reflectnoise.dds, and the Blend to Multiply.



Now using Edit->Material Operations->Replace Material you should replace each of your
remaining materials with rreflect. The geometry will turn magenta as you do this as we do not have
the textures but do not worry. When finished the Edit->Purge->Unused Materials should be used
again and when the only material you have left is rreflect this stage is completed.

9.4. Correcting lighting properties

The lighting properties of these objects need to set to make sure they act correctly within the GTR2
light model. Use Edit->Select All Display and from the sub-menu select Objects, then Tags and
NOT Lit at Night.

9.5. Move geometry

It is almost time to save these objects but first the geometry has to be raised a little so that these
objects appear over the track surface. Use Edit->Translate Model and set the Z value to 0.01 when
you click OK all the objects will be lifted by 1cm which you probably will not see. Now with File-
>Save As GTR2->Save Objects select the GTR2\Gamedata\Locations\MyTrack\Objs
folder to save the objects.

9.6. Adding objects to MyTrack.trk

The last stage is to open the new _output.trk in the Objs folder and copy all its contents to the
bottom of MyTrack.Trk.

9.7. Testing and troubleshooting

In GTR2, set the rainfall to 100% and drive the track. You should see some reflections of objects in
water lying on the track. In a replay you should see reflections of the car.

If the track did not load it’s probable that you have anincorrect texture name for one of the stages
of the rreflect material. If there are no reflections it could be that the material name is incorrectly
spelt or you have not named one of the .gmt files as rreflect01.gmt. Strange lighting as you enter or
leave each section of the track will be due to having not set the tags correctly for the lighting model.

10. Creating GTR2 compressed .GTR files

If you are going to release your track then at some point you should pack the .GMT and .DDS files
to .GTR files.

You can do this using 3DSimED Tools->Pack Files->GTR2 .GTR

Select all of the .gmt files from GTR2\Gamedata\Locations\MyTrack\Objs
and Save As GTR2\GameData\Locations\MyTrack\MyTrack.GTR

Next, select all of the .dds files from GTR2\Gamedata\Locations\MyTrack\Objs and
Save As GTR2\GameData\Locations\MyTrack\MyTrackmap.GTR

Once you have done this you should delete the .GMT and .DDS files.

You will also need to modify the MyTrack.trk file in
GTR2\GameData\Locations\MyTrack\MyTrack so that the header has all these entries:-

CUBEASF



CUBEASF

//-------------------------------------------------------

SearchPath=GAMEDATA\LOCATIONS\SHARED
SearchPath=GAMEDATA\LOCATIONS\NONAME
SearchPath=GAMEDATA\LOCATIONS\NONAME\OBJS
//-------------------------------------------------------

MASFile=Skies_central.gtr
MASFile=teammaps2.gtr
MASFile=Misc.gtr

MASFile=MYTRACK.GTR
MASFile=MYTRACKMAP.GTR

Double-check everything has worked by driving the track in GTR2.


